Star InactiveStar InactiveStar InactiveStar InactiveStar Inactive
 

 

Updating versions of Joomla between 2.5 and 3.5

The introduction of Joomla 1.6 brought in several new features, one of which was 'Automatic update'.  Because of the changes made in the databases during the various releases of 1.6 and 1.7 'Automatic updates' is best not used for Joomla versions below 1.6.5.  Using 'Automatic updates' for 1.6.5, 1.6.6 and 1.7.0 has to be done twice to bring Joomla up to the current version.

Upgrading to Joomla 3.4 is relatively easy ... the difficulty depends on the 3rd party extensions that you have on your site.  Some 2.5 extensions are not compatible with 3.4 while other extensions are compatible but require a different zip file to be installed.  Another complication is that some 3rd party extensions (which are compatable with joomla 2.5 and 3.4) that have one install zip will install different files depending on the version of Joomla they are installed into.

Preparation

      1. Use Akeeba Backup to create a copy of your site in a new folder or locally on your computer and use the copy to do the migration.  Select the correct version of Akeeba from https://www.akeebabackup.com/compatibility.html
      2. Make sure you Joomla version is 2.5.28 and that all the 3rd party extensions are up to date.
      3. Check your server meets the minimum requirements for Joomla 3.x series.
      4. Disable the 'Remember me' Plugin in the Plugins Manager.
      5. Make a list of all you 3rd party extensions and note which are compatible with .3.4
      6. Uninstall all the non compatible 3rd party extensions and disable all the other 3rd party extensions.
        1. Check with the authors of the 3rd party extensions to see if they have upgrade instructions specific to their extension.  Some extensions may require uninstalling the files but leaving their database tables intact !!!
        2. If you use a custom Template check it is compatible with Joomla 3.4.  If you are in any doubt then set Beez 5 as default.
      7. Back up your changes.

 

Completing the upgrade

      1. Navigate to Components >>> Joomla! Update.
        1.  Set the Options to STS ... If Joomla 3.4 does not show then purge cache .
      2. Click to update.
        Note:  You can also upgrade by installing the Joomla 3.4 full package zip via the Extension manager.
      3. Install the latest versions of your 3rd party extensions (taking care to follow any instructions specific to each extenstion).
      4.  Re-enable all your 3rd party extensions.
        1. Set your custom Template or install a new one if you need to.
      5. Re-enable your 'Remember me' Plugin.
      6. Move your active site to a subfolder
      7. Move the upgraded site to your website root (edit the paths in the configuration.php and .htaccess if necessary).

 

 

Useful links

 

Three easy steps